<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width,initial-scale=1.0">
		<title>Behind the Scenes of Aquaman &#8211; Static Multimedia</title>
<link rel='dns-prefetch' href='//player.vimeo.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Static Multimedia &raquo; Feed" href="http://staticmultimedia.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Static Multimedia &raquo; Comments Feed" href="http://staticmultimedia.com/comments/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.3.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.3.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-127444562-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-127444562-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('set', 'anonymizeIp', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/staticmultimedia.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='universal_video_player_site_css-css'  href='http://staticmultimedia.com/wp-content/plugins/universal_video_player/universal_video_player/universal_video_player.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='pt_sans-googleFonts-css'  href='https://fonts.googleapis.com/css?family=PT+Sans%3A400%2C700&#038;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='gridlove-fonts-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A400%7CLato%3A400%2C700%7CCabin%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;ver=1.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='gridlove-main-css'  href='http://staticmultimedia.com/wp-content/themes/gridlove/assets/css/min.css?ver=1.7.1' type='text/css' media='all' />
<style id='gridlove-main-inline-css' type='text/css'>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</style>
<!-- `jetpack-widget-social-icons-styles` is included in the concatenated jetpack.css -->
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/6.7/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='http://staticmultimedia.com/wp-content/plugins/universal_video_player/universal_video_player/js/jquery.mousewheel.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://staticmultimedia.com/wp-content/plugins/universal_video_player/universal_video_player/js/jquery.touchSwipe.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://staticmultimedia.com/wp-content/plugins/universal_video_player/universal_video_player/js/screenfull.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://player.vimeo.com/api/player.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://staticmultimedia.com/wp-content/plugins/universal_video_player/universal_video_player/js/universal_video_player.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://staticmultimedia.com/wp-content/plugins/universal_video_player/universal_video_player/js/google_a.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"http:\/\/staticmultimedia.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://staticmultimedia.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.js?ver=7.3.0'></script>
<link rel='https://api.w.org/' href='http://staticmultimedia.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://staticmultimedia.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://staticmultimedia.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='&#8216;Fallout 76&#8217; Celebrates Worldwide Release with Live-Action Trailer' href='http://staticmultimedia.com/video-games/fallout-76-celebrates-worldwide-release-with-live-action-trailer/' />
<link rel='next' title='&#8216;Blazing Chrome&#8217; Channels Classic Arcade Action Coming Soon' href='http://staticmultimedia.com/video-games/blazing-chrome-channels-classic-arcade-action-coming-soon/' />
<meta name="generator" content="WordPress 4.9.8" />
<link rel="canonical" href="http://staticmultimedia.com/movies/behind-the-scenes-of-auquaman/" />
<link rel='shortlink' href='https://wp.me/p3poXn-xT4' />
<link rel="alternate" type="application/json+oembed" href="http://staticmultimedia.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fbehind-the-scenes-of-auquaman%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://staticmultimedia.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fbehind-the-scenes-of-auquaman%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Behind the Scenes of Aquaman" />
<meta property="og:url" content="http://staticmultimedia.com/movies/behind-the-scenes-of-auquaman/" />
<meta property="og:description" content="From Warner Bros. Pictures and director James Wan comes an action-packed adventure that spans the vast, visually breathtaking underwater world of the seven seas, Aquaman, starring Jason Momoa in th…" />
<meta property="article:published_time" content="2018-11-14T20:26:23+00:00" />
<meta property="article:modified_time" content="2018-11-15T01:11:42+00:00" />
<meta property="og:site_name" content="Static Multimedia" />
<meta property="og:image" content="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/behind-the-scenes-of-auquaman.jpg?fit=1200%2C675" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="675" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@staticmm" />
<meta name="twitter:site" content="@staticmm" />
<meta name="twitter:text:title" content="Behind the Scenes of Aquaman" />
<meta name="twitter:image" content="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/behind-the-scenes-of-auquaman.jpg?fit=1200%2C675&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<style type="text/css">html, body { height: 100%; width: 100%; } .gridlove-header-wrapper { background: #AA076B; /* fallback for old browsers */ background: -webkit-linear-gradient(to right, #61045F, #AA076B); /* Chrome 10-25, Safari 5.1-6 */ background: linear-gradient(to right, #61045F, #AA076B); /* W3C, IE 10+/ Edge, Firefox 16+, Chrome 26+, Opera 12+, Safari 7+ */ border-bottom:1px solid #999999; } .entry-category a, .gridlove-action-link, .gridlove-pill { border-radius: 5px !important; } p { line-height:1.75; font-size: 1.125em; } .gridlove-content { max-width: 1200px; } .gridlove-format-icon { display: none; }</style></head>

<body class="post-template-default single single-post postid-130266 single-format-video unknown gridlove-cover-overlay-off">
	
		
	<header id="header" class="gridlove-site-header hidden-md-down  gridlove-header-shadow">
			
			
			<div class="gridlove-header-wrapper">
    <div class="gridlove-header-1 gridlove-header-middle container">
        
        <div class="gridlove-slot-l">
            
<div class="gridlove-site-branding  ">
			<span class="site-title h1"><a href="http://staticmultimedia.com/" rel="home"><img class="gridlove-logo" src="http://staticmultimedia.com/wp-content/uploads/2018/08/staticmm_logo_5.png" alt="Static Multimedia"></a></span>
	
	
</div>

        </div>

        <div class="gridlove-slot-r">
            <nav class="gridlove-main-navigation">	
				<ul id="menu-blog-menu" class="gridlove-main-nav gridlove-menu"><li id="menu-item-126244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-126244"><a href="http://staticmultimedia.com/fashion-lifestyle/">Fashion &#038; Lifestyle</a></li>
<li id="menu-item-126245" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-126245"><a href="http://staticmultimedia.com/movies/">Movies</a></li>
<li id="menu-item-124476" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-124476"><a href="http://staticmultimedia.com/music/">Music</a></li>
<li id="menu-item-124829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-124829"><a href="http://staticmultimedia.com/tv-streaming/">TV &#038; Streaming</a></li>
<li id="menu-item-126246" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-126246"><a href="http://staticmultimedia.com/video-games/">Video Games</a></li>
<li id="menu-item-124270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-124270"><a>Videos</a>
<ul class="sub-menu">
	<li id="menu-item-124269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-124269"><a href="http://staticmultimedia.com/movie-trailers/">Movie Trailers &#038; Clips</a></li>
	<li id="menu-item-124258" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-124258"><a href="http://staticmultimedia.com/video-game-trailers/">Video Game Trailers &#038; Gameplay</a></li>
</ul>
</li>
</ul>	</nav>            	<ul class="gridlove-actions gridlove-menu">
					<li class="gridlove-actions-button gridlove-social-icons">
	<span>
		<i class="fa fa-share-alt"></i>
	</span>
	<ul class="sub-menu">
	<li>
		<ul id="menu-social-media" class="gridlove-soc-menu"><li id="menu-item-120989" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-120989"><a href="https://twitter.com/staticmm"><span class="gridlove-social-name">Twitter</span></a></li>
<li id="menu-item-120988" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-120988"><a href="https://www.facebook.com/staticmm/"><span class="gridlove-social-name">Facebook</span></a></li>
<li id="menu-item-120999" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-120999"><a href="https://www.instagram.com/staticmm_style/"><span class="gridlove-social-name">Instagram</span></a></li>
</ul>	</li>
	</ul>
</li>
			</ul>
        </div>
        
    </div>
</div>

			
	</header>

	<div id="gridlove-header-responsive" class="gridlove-header-responsive hidden-lg-up">

	<div class="container">
		
		
<div class="gridlove-site-branding  ">
			<span class="site-title h1"><a href="http://staticmultimedia.com/" rel="home"><img class="gridlove-logo" src="http://staticmultimedia.com/wp-content/uploads/2018/08/staticmm_logo_5.png" alt="Static Multimedia"></a></span>
	
	
</div>


		<ul class="gridlove-actions gridlove-menu">

								<li class="gridlove-actions-button gridlove-social-icons">
	<span>
		<i class="fa fa-share-alt"></i>
	</span>
	<ul class="sub-menu">
	<li>
		<ul id="menu-social-media-1" class="gridlove-soc-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-120989"><a href="https://twitter.com/staticmm"><span class="gridlove-social-name">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-120988"><a href="https://www.facebook.com/staticmm/"><span class="gridlove-social-name">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-120999"><a href="https://www.instagram.com/staticmm_style/"><span class="gridlove-social-name">Instagram</span></a></li>
</ul>	</li>
	</ul>
</li>
				
			<li class="gridlove-actions-button">
	<span class="gridlove-sidebar-action">
		<i class="fa fa-bars"></i>
	</span>
</li>	
</ul>
	</div>

</div>






<div id="content" class="gridlove-site-content container gridlove-sidebar-right">

    <div class="row">

    	
	
	
		<div class="gridlove-share-wrapper">
			<div class="gridlove-share gridlove-box gridlove-sticky-share">

									<a href="javascript:void(0);" class="gridlove-facebook gridlove-share-item" data-url="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fbehind-the-scenes-of-auquaman%2F&amp;t=Behind%20the%20Scenes%20of%20Aquaman"><i class="fa fa-facebook"></i></a>									<a href="javascript:void(0);" class="gridlove-twitter gridlove-share-item" data-url="http://twitter.com/intent/tweet?url=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fbehind-the-scenes-of-auquaman%2F&amp;text=Behind%20the%20Scenes%20of%20Aquaman"><i class="fa fa-twitter"></i></a>									<a href="javascript:void(0);"  class="gridlove-reddit gridlove-share-item" data-url="http://www.reddit.com/submit?url=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fbehind-the-scenes-of-auquaman%2F&amp;title=Behind%20the%20Scenes%20of%20Aquaman"><i class="fa fa-reddit-alien"></i></a>									<a href="javascript:void(0);"  class="gridlove-pinterest gridlove-share-item" data-url="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fbehind-the-scenes-of-auquaman%2F&amp;media=https%3A%2F%2Fi0.wp.com%2Fstaticmultimedia.com%2Fwp-content%2Fuploads%2F2018%2F11%2Fbehind-the-scenes-of-auquaman.jpg%3Ffit%3D1280%252C720&amp;description=Behind%20the%20Scenes%20of%20Aquaman"><i class="fa fa-pinterest-p"></i></a>									<a href="javascript:void(0);"  class="gridlove-gplus gridlove-share-item" data-url="https://plus.google.com/share?url=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fbehind-the-scenes-of-auquaman%2F"><i class="fa fa-google-plus"></i></a>									<a href="javascript:void(0);"  class="gridlove-stumbleupon gridlove-share-item" data-url="http://www.stumbleupon.com/badge?url=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fbehind-the-scenes-of-auquaman%2F&amp;title=Behind%20the%20Scenes%20of%20Aquaman"><i class="fa fa-stumbleupon"></i></a>				
			</div>
		</div>

		

        <div class="gridlove-content gridlove-single-layout-1">

                            
                <article id="post-130266" class="gridlove-box box-vm post-130266 post type-post status-publish format-video has-post-thumbnail hentry category-movies post_format-post-format-video">
	
		<div class="entry-media"><iframe width="770" height="433" src="https://www.youtube.com/embed/shdb-Bn-kMo?controls=0" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
 
                        
<div class="box-inner-p-bigger box-single">

    <div class="entry-header">
		<div class="entry-category">
	    
	    	        <a href="http://staticmultimedia.com/movies/" class="gridlove-cat gridlove-cat-5">Movies</a>	    	</div>

    <h1 class="entry-title">Behind the Scenes of Aquaman</h1>
        	<div class="entry-meta"><div class="meta-item meta-author"><span class="vcard author"><span class="fn"><a href="http://staticmultimedia.com/author/katiestreeter/"><img alt='' src='http://2.gravatar.com/avatar/e19ebdb1952649c692448caa8e821974?s=24&#038;d=mm&#038;r=g' class='avatar avatar-24 photo' height='24' width='24' /> Katie Steeter</a></span></span></div><div class="meta-item meta-date"><span class="updated">Wed, Nov 14</span></div></div>
    
</div>
    
	<div class="gridlove-ad"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- above post content ad -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6137011645901412"
     data-ad-slot="1718415478"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

<div class="entry-content">
                            
    <p>From Warner Bros. Pictures and director James Wan comes an action-packed adventure that spans the vast, visually breathtaking underwater world of the seven seas, <em>Aquaman</em>, starring Jason Momoa in the title role.  The film reveals the origin story of half-human, half-Atlantean Arthur Curry and takes him on the journey of his lifetime—one that will not only force him to face who he really is, but to discover if he is worthy of who he was born to be…a king.</p>
<p>The film also stars Amber Heard (<em>Justice League, Magic Mike XXL</em>) as Mera, a fierce warrior and Aquaman’s ally throughout his journey; Oscar nominee Willem Dafoe (<em>Platoon, Spider-Man 2</em>) as Vulko, council to the Atlantean throne; Patrick Wilson (<em>The Conjuring films, Watchmen</em>) as Orm/Ocean Master, the present King of Atlantis; Dolph Lundgren (<em>The Expendables</em> films) as Nereus, King of the Atlantean tribe Xebel; Yahya Abdul-Mateen II (Netflix’s “The Get Down”) as the vengeful Black Manta; and Oscar winner Nicole Kidman (<em>The Hours, Lion</em>) as Arthur’s mom, Atlanna; as well as Ludi Lin (<em>Power Rangers</em>) as Captain Murk, Atlantean Commando; and Temuera Morrison (<em>Star Wars: Episode II – Attack of the Clones, Green Lantern</em>) as Arthur’s dad, Tom Curry.</p>
<p>In theaters December 21st.</p>

    
    
</div>
    
    
	
	
		<nav class="gridlove-prev-next-nav">
				<div class="gridlove-prev-link">
				
					
						<a href="http://staticmultimedia.com/movies/backtrace-new-crime-thriller-premieres-december/">
							<span class="gridlove-pn-ico"><i class="fa fa fa-chevron-left"></i></span>
							<span class="gridlove-pn-link">Backtrace &#8211; New  Crime Thriller Premieres December</span>
						</a>

					

								</div>
				<div class="gridlove-next-link">
				
					
						<a href="http://staticmultimedia.com/movies/digital-week-november-13th/">
							<span class="gridlove-pn-ico"><i class="fa fa fa-chevron-right"></i></span>
							<span class="gridlove-pn-link">Digital Week &#8211; November 13th</span>
						</a>
					

								</div>

		</nav>

	


</div>

</article>
                            

            
            
            
            
    
    
        
            <div class="gridlove-related">
                <div class="gridlove-module">

                    <div class="module-header"><div class="module-title"><h4 class="h2">You may also like</h2></div></div>
                                        <div class="row">
                        
                            <div class="col-lg-6 col-md-6 col-sm-12">
                                <article class="gridlove-post gridlove-post-a gridlove-box  post-130274 post type-post status-publish format-video has-post-thumbnail hentry category-movies post_format-post-format-video">

            <div class="entry-image">
            <a href="http://staticmultimedia.com/movies/backtrace-new-crime-thriller-premieres-december/" title="Backtrace &#8211; New  Crime Thriller Premieres December"><img width="370" height="150" src="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/backtrace-new-crime-thriller-pre.jpg?resize=370%2C150" class="attachment-gridlove-a4 size-gridlove-a4 wp-post-image" alt="" srcset="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/backtrace-new-crime-thriller-pre.jpg?resize=370%2C150 370w, https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/backtrace-new-crime-thriller-pre.jpg?zoom=2&amp;resize=370%2C150 740w, https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/backtrace-new-crime-thriller-pre.jpg?zoom=3&amp;resize=370%2C150 1110w" sizes="(max-width: 370px) 100vw, 370px" /></a>
            <div class="entry-category">
                
                            </div>
        </div>
    

    <div class="box-inner-p">
        <div class="box-inner-ellipsis">
            <h2 class="entry-title h3"><a href="http://staticmultimedia.com/movies/backtrace-new-crime-thriller-premieres-december/">Backtrace &#8211; New  Crime Thriller Premieres December</a></h2>        </div>
                    <div class="entry-meta"><div class="meta-item meta-author"><span class="vcard author"><span class="fn"><a href="http://staticmultimedia.com/author/julie-burke/"><img alt='' src='http://2.gravatar.com/avatar/5e7bed84d37614fff8e8c03d38da5836?s=24&#038;d=mm&#038;r=g' class='avatar avatar-24 photo' height='24' width='24' /> Julie Burke</a></span></span></div><div class="meta-item meta-date"><span class="updated">Wed, Nov 14</span></div></div>
            </div>

</article>                            </div>

                        
                            <div class="col-lg-6 col-md-6 col-sm-12">
                                <article class="gridlove-post gridlove-post-a gridlove-box  post-130251 post type-post status-publish format-standard has-post-thumbnail hentry category-digital-week category-movies tag-blu-ray tag-dvd">

            <div class="entry-image">
            <a href="http://staticmultimedia.com/movies/digital-week-november-13th/" title="Digital Week &#8211; November 13th"><img width="370" height="150" src="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/digital13.jpg?resize=370%2C150" class="attachment-gridlove-a4 size-gridlove-a4 wp-post-image" alt="" srcset="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/digital13.jpg?resize=370%2C150 370w, https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/digital13.jpg?zoom=2&amp;resize=370%2C150 740w, https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/digital13.jpg?zoom=3&amp;resize=370%2C150 1110w" sizes="(max-width: 370px) 100vw, 370px" /></a>
            <div class="entry-category">
                
                            </div>
        </div>
    

    <div class="box-inner-p">
        <div class="box-inner-ellipsis">
            <h2 class="entry-title h3"><a href="http://staticmultimedia.com/movies/digital-week-november-13th/">Digital Week &#8211; November 13th</a></h2>        </div>
                    <div class="entry-meta"><div class="meta-item meta-author"><span class="vcard author"><span class="fn"><a href="http://staticmultimedia.com/author/kevin-filipski/"><img alt='' src='http://2.gravatar.com/avatar/2cb2584f91d0a16f3e62e52fd1f85523?s=24&#038;d=mm&#038;r=g' class='avatar avatar-24 photo' height='24' width='24' /> Kevin Filipski</a></span></span></div><div class="meta-item meta-date"><span class="updated">Wed, Nov 14</span></div></div>
            </div>

</article>                            </div>

                        
                            <div class="col-lg-6 col-md-6 col-sm-12">
                                <article class="gridlove-post gridlove-post-a gridlove-box  post-130228 post type-post status-publish format-video has-post-thumbnail hentry category-movies post_format-post-format-video">

            <div class="entry-image">
            <a href="http://staticmultimedia.com/movies/debut-trailer-perfect-strangers-perfectos-desconocidos/" title="Debut Trailer: Perfect Strangers (Perfectos Desconocidos)"><img width="370" height="150" src="https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/debut-trailer-perfect-strangers.jpg?resize=370%2C150" class="attachment-gridlove-a4 size-gridlove-a4 wp-post-image" alt="" srcset="https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/debut-trailer-perfect-strangers.jpg?resize=370%2C150 370w, https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/debut-trailer-perfect-strangers.jpg?zoom=2&amp;resize=370%2C150 740w, https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/debut-trailer-perfect-strangers.jpg?zoom=3&amp;resize=370%2C150 1110w" sizes="(max-width: 370px) 100vw, 370px" /></a>
            <div class="entry-category">
                
                            </div>
        </div>
    

    <div class="box-inner-p">
        <div class="box-inner-ellipsis">
            <h2 class="entry-title h3"><a href="http://staticmultimedia.com/movies/debut-trailer-perfect-strangers-perfectos-desconocidos/">Debut Trailer: Perfect Strangers (Perfectos Desconocidos)</a></h2>        </div>
                    <div class="entry-meta"><div class="meta-item meta-author"><span class="vcard author"><span class="fn"><a href="http://staticmultimedia.com/author/katiestreeter/"><img alt='' src='http://2.gravatar.com/avatar/e19ebdb1952649c692448caa8e821974?s=24&#038;d=mm&#038;r=g' class='avatar avatar-24 photo' height='24' width='24' /> Katie Steeter</a></span></span></div><div class="meta-item meta-date"><span class="updated">Tue, Nov 13</span></div></div>
            </div>

</article>                            </div>

                        
                            <div class="col-lg-6 col-md-6 col-sm-12">
                                <article class="gridlove-post gridlove-post-a gridlove-box  post-130216 post type-post status-publish format-standard has-post-thumbnail hentry category-movies">

            <div class="entry-image">
            <a href="http://staticmultimedia.com/movies/new-trailer-alita-battle-angel-an-epic-adventure-of-hope-and-empowerment/" title="New Trailer: ALITA: Battle Angel &#8211; an Epic Adventure of Hope and Empowerment"><img width="370" height="150" src="https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/Alita_Still.jpg?resize=370%2C150" class="attachment-gridlove-a4 size-gridlove-a4 wp-post-image" alt="" srcset="https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/Alita_Still.jpg?resize=370%2C150 370w, https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/Alita_Still.jpg?zoom=2&amp;resize=370%2C150 740w, https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/Alita_Still.jpg?zoom=3&amp;resize=370%2C150 1110w" sizes="(max-width: 370px) 100vw, 370px" /></a>
            <div class="entry-category">
                
                            </div>
        </div>
    

    <div class="box-inner-p">
        <div class="box-inner-ellipsis">
            <h2 class="entry-title h3"><a href="http://staticmultimedia.com/movies/new-trailer-alita-battle-angel-an-epic-adventure-of-hope-and-empowerment/">New Trailer: ALITA: Battle Angel &#8211; an Epic Adventure of Hope and Empowerment</a></h2>        </div>
                    <div class="entry-meta"><div class="meta-item meta-author"><span class="vcard author"><span class="fn"><a href="http://staticmultimedia.com/author/julie-burke/"><img alt='' src='http://2.gravatar.com/avatar/5e7bed84d37614fff8e8c03d38da5836?s=24&#038;d=mm&#038;r=g' class='avatar avatar-24 photo' height='24' width='24' /> Julie Burke</a></span></span></div><div class="meta-item meta-date"><span class="updated">Tue, Nov 13</span></div></div>
            </div>

</article>                            </div>

                                            </div>
                </div>
            </div>

        
        
    

        </div>

        

	<div class="gridlove-sidebar">

						<div id="gridlove_posts_widget-2" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Popular</h4>
								
		<div class="gridlove-posts-widget ">

							
								
				<article class="post-130278 post type-post status-publish format-video has-post-thumbnail hentry category-music post_format-post-format-video">

		            		                <div class="entry-image">
		                <a href="http://staticmultimedia.com/music/yung-lean-friday-the-13th-music-video/" title="Yung Lean &#8211; &#8220;friday the 13th&#8221; Music Video">
		                   	<img width="80" height="60" src="https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/yung-lean-friday-the-13th-music.jpg?resize=80%2C60" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" srcset="https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/yung-lean-friday-the-13th-music.jpg?resize=80%2C60 80w, https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/yung-lean-friday-the-13th-music.jpg?zoom=2&amp;resize=80%2C60 160w, https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/yung-lean-friday-the-13th-music.jpg?zoom=3&amp;resize=80%2C60 240w" sizes="(max-width: 80px) 100vw, 80px" />		                </a>
		                </div>
		            
		            <div class="entry-header">
		                <h6><a href="http://staticmultimedia.com/music/yung-lean-friday-the-13th-music-video/">Yung Lean &#8211; &#8220;friday the 13th&#8221; Music Video</a></h6>		                		            </div>

				</article>

				
				
							
								
				<article class="post-130274 post type-post status-publish format-video has-post-thumbnail hentry category-movies post_format-post-format-video">

		            		                <div class="entry-image">
		                <a href="http://staticmultimedia.com/movies/backtrace-new-crime-thriller-premieres-december/" title="Backtrace &#8211; New  Crime Thriller Premieres December">
		                   	<img width="80" height="60" src="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/backtrace-new-crime-thriller-pre.jpg?resize=80%2C60" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" srcset="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/backtrace-new-crime-thriller-pre.jpg?resize=80%2C60 80w, https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/backtrace-new-crime-thriller-pre.jpg?zoom=2&amp;resize=80%2C60 160w, https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/backtrace-new-crime-thriller-pre.jpg?zoom=3&amp;resize=80%2C60 240w" sizes="(max-width: 80px) 100vw, 80px" />		                </a>
		                </div>
		            
		            <div class="entry-header">
		                <h6><a href="http://staticmultimedia.com/movies/backtrace-new-crime-thriller-premieres-december/">Backtrace &#8211; New  Crime Thriller Premieres December</a></h6>		                		            </div>

				</article>

				
				
							
								
				<article class="post-130269 post type-post status-publish format-standard has-post-thumbnail hentry category-video-games">

		            		                <div class="entry-image">
		                <a href="http://staticmultimedia.com/video-games/blazing-chrome-channels-classic-arcade-action-coming-soon/" title="&#8216;Blazing Chrome&#8217; Channels Classic Arcade Action Coming Soon">
		                   	<img width="80" height="60" src="https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/Blazing-Chrome-1.png?resize=80%2C60" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" srcset="https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/Blazing-Chrome-1.png?resize=80%2C60 80w, https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/Blazing-Chrome-1.png?zoom=2&amp;resize=80%2C60 160w, https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2018/11/Blazing-Chrome-1.png?zoom=3&amp;resize=80%2C60 240w" sizes="(max-width: 80px) 100vw, 80px" />		                </a>
		                </div>
		            
		            <div class="entry-header">
		                <h6><a href="http://staticmultimedia.com/video-games/blazing-chrome-channels-classic-arcade-action-coming-soon/">&#8216;Blazing Chrome&#8217; Channels Classic Arcade Action Coming Soon</a></h6>		                		            </div>

				</article>

				
				
			
		</div>

		
		
		</div><div id="custom_html-3" class="widget_text widget gridlove-box widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar - Movies -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6137011645901412"
     data-ad-slot="2821288746"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="custom_html-2" class="widget_text widget gridlove-box widget_custom_html"><div class="textwidget custom-html-widget"><div id="amzn-assoc-ad-78b968de-b7b1-4f53-8f0b-0e833c879ebc"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=78b968de-b7b1-4f53-8f0b-0e833c879ebc"></script></div></div>		
		
	</div>

    </div>
        
</div>



	<div class="conatiner"><div class="gridlove-ad"><iframe src="//rcm-na.amazon-adsystem.com/e/cm?o=1&p=48&l=ur1&category=musicandentertainmentrot&f=ifr&linkID=2e13f84f28f402e1452f8a0c18353d92&t=staticmm-20&tracking_id=staticmm-20" width="728" height="90" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe></div></div>

<div id="footer" class="gridlove-footer">

	
	        <div class="container">
	            <div class="row">
	                
											<div class="col-lg-3 col-md-6 col-sm-12">
													</div>
											<div class="col-lg-3 col-md-6 col-sm-12">
													</div>
											<div class="col-lg-3 col-md-6 col-sm-12">
													</div>
											<div class="col-lg-3 col-md-6 col-sm-12">
													</div>
					
	            </div>
	        </div>

	
    
	        <div class="gridlove-copyright">
	            <div class="container">
	                <p style="text-align: center">Copyright &copy; Static Multimedia</p>	            </div>
	        </div>

	
</div>

<div class="gridlove-sidebar-action-wrapper">

	<span class="gridlove-action-close"><i class="fa fa-times" aria-hidden="true"></i></span>

	<div class="gridlove-sidebar-action-inside">

		<div class="hidden-lg-up widget gridlove-box widget_nav_menu">
					<ul id="menu-blog-menu-1" class="gridlove-mobile-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-126244"><a href="http://staticmultimedia.com/fashion-lifestyle/">Fashion &#038; Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-126245"><a href="http://staticmultimedia.com/movies/">Movies</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-124476"><a href="http://staticmultimedia.com/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-124829"><a href="http://staticmultimedia.com/tv-streaming/">TV &#038; Streaming</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-126246"><a href="http://staticmultimedia.com/video-games/">Video Games</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-124270"><a>Videos</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-124269"><a href="http://staticmultimedia.com/movie-trailers/">Movie Trailers &#038; Clips</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-124258"><a href="http://staticmultimedia.com/video-game-trailers/">Video Game Trailers &#038; Gameplay</a></li>
</ul>
</li>
</ul>		</div>

		

	</div>

</div>

<div class="gridlove-sidebar-action-overlay"></div>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/widget.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/mouse.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/slider.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/progressbar.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/effect.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/ui/effect-drop.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/6.7/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201846'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/imagesloaded.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/masonry.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/jquery/jquery.masonry.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gridlove_js_settings = {"rtl_mode":"","header_sticky":"","header_sticky_offset":"50","header_sticky_up":"","logo":"http:\/\/staticmultimedia.com\/wp-content\/uploads\/2018\/08\/staticmm_logo_5.png","logo_retina":"","logo_mini":"","logo_mini_retina":"","gridlove_gallery":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://staticmultimedia.com/wp-content/themes/gridlove/assets/js/min.js?ver=1.7.1'></script>
<script type='text/javascript' src='https://c0.wp.com/c/4.9.8/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201846.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.7',blog:'50383145',post:'130266',tz:'0',srv:'staticmultimedia.com'} ]);
	_stq.push([ 'clickTrackerInit', '50383145', '130266' ]);
</script>
</body>

</html>