<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width,initial-scale=1.0">
		<title>Director Brent Ryan Green Releases &#8220;The Veil&#8221; &#8211; Static Multimedia</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Static Multimedia &raquo; Feed" href="http://staticmultimedia.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Static Multimedia &raquo; Comments Feed" href="http://staticmultimedia.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/staticmultimedia.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='simple-payments-css'  href='http://staticmultimedia.com/wp-content/plugins/jetpack/modules/simple-payments/simple-payments.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='gridlove-fonts-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A400%7CLato%3A400%2C700%7CCabin%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;ver=1.3' type='text/css' media='all' />
<link rel='stylesheet' id='gridlove-main-css'  href='http://staticmultimedia.com/wp-content/themes/gridlove/assets/css/min.css?ver=1.3' type='text/css' media='all' />
<style id='gridlove-main-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='meks-ads-widget-css'  href='http://staticmultimedia.com/wp-content/plugins/meks-easy-ads-widget/css/style.css?ver=2.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://staticmultimedia.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.2.1' type='text/css' media='all' />
<script type='text/javascript' src='http://staticmultimedia.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://staticmultimedia.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://staticmultimedia.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://staticmultimedia.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://staticmultimedia.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Writer-director William Scherer Discusses New Hitchcockian Thriller' href='http://staticmultimedia.com/movies/writer-director-william-scherer-discusses-new-hitchcockian-thriller/' />
<link rel='next' title='Sonic Mania Delayed Two Weeks on PC' href='http://staticmultimedia.com/video-games/sonic-mania-delayed-two-weeks-on-pc/' />
<meta name="generator" content="WordPress 4.8.1" />
<link rel="canonical" href="http://staticmultimedia.com/movies/director-brent-ryan-green-releases-the-veil/" />
<link rel='shortlink' href='http://wp.me/p3poXn-uLn' />
<link rel="alternate" type="application/json+oembed" href="http://staticmultimedia.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fdirector-brent-ryan-green-releases-the-veil%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://staticmultimedia.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fdirector-brent-ryan-green-releases-the-veil%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Director Brent Ryan Green Releases &#8220;The Veil&#8221;" />
<meta property="og:url" content="http://staticmultimedia.com/movies/director-brent-ryan-green-releases-the-veil/" />
<meta property="og:description" content="Growing up, writer/director/producer Brent Ryan Green didn&#8217;t want to make movies. So how did it happen that the producer turned director is behind one of the biggest fantasy action movies ope…" />
<meta property="article:published_time" content="2017-08-14T12:39:10+00:00" />
<meta property="article:modified_time" content="2017-08-14T12:39:10+00:00" />
<meta property="og:site_name" content="Static Multimedia" />
<meta property="og:image" content="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/theveil.jpg?fit=1100%2C400" />
<meta property="og:image:width" content="1100" />
<meta property="og:image:height" content="400" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@staticmm" />
<meta name="twitter:image" content="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/theveil.jpg?fit=1100%2C400&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@staticmm" />
<style type="text/css">.entry-category a, .gridlove-action-link, .gridlove-pill { border-radius: 5px !important; }</style></head>

<body class="post-template-default single single-post postid-118257 single-format-standard unknown">
	
		
	<header id="header" class="gridlove-site-header hidden-md-down  gridlove-header-shadow">
			
			
			<div class="gridlove-header-wrapper">
    <div class="gridlove-header-1 gridlove-header-middle container">
        
        <div class="gridlove-slot-l">
            
<div class="gridlove-site-branding  ">
			<span class="site-title h1"><a href="http://staticmultimedia.com/" rel="home"><img class="gridlove-logo" src="http://staticmultimedia.com/wp-content/uploads/2017/07/logo_main.png" alt="Static Multimedia"></a></span>
	
	
</div>

        </div>

        <div class="gridlove-slot-r">
            <nav class="gridlove-main-navigation">	
				<ul id="menu-blog-menu" class="gridlove-main-nav gridlove-menu"><li id="menu-item-117607" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117607"><a href="http://www.staticmultimedia.com">Front Page</a></li>
<li id="menu-item-105659" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-105659"><a href="http://www.staticmultimedia.com">Articles</a>
<ul  class="sub-menu">
	<li id="menu-item-117550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117550"><a href="http://staticmultimedia.com/category/fashion-lifestyle/">Fashion &#038; Lifestyle</a></li>
	<li id="menu-item-112054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112054"><a href="http://staticmultimedia.com/movies">Movies</a></li>
	<li id="menu-item-105663" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-105663"><a href="http://staticmultimedia.com/video-games">Video Games</a></li>
</ul>
</li>
<li id="menu-item-117986" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117986"><a href="http://audio.staticmultimedia.com">Audio</a></li>
<li id="menu-item-117545" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-117545"><a href="http://video.staticmultimedia.com">Video</a>
<ul  class="sub-menu">
	<li id="menu-item-117560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117560"><a href="http://video.staticmultimedia.com/category/movies/">Movies</a></li>
	<li id="menu-item-117561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117561"><a href="http://video.staticmultimedia.com/category/music/">Music</a></li>
	<li id="menu-item-117562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117562"><a href="http://video.staticmultimedia.com/category/video-games/">Video Games</a></li>
</ul>
</li>
<li id="menu-item-117987" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117987"><a>//</a></li>
<li id="menu-item-117546" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117546"><a href="http://cityguide.staticmultimedia.com">City Guide</a></li>
</ul>	</nav>            	<ul class="gridlove-actions gridlove-menu">
					<li class="gridlove-actions-button gridlove-action-search">
	<span>
		<i class="fa fa-search"></i>
	</span>
	<ul class="sub-menu">
		<li>
			<form class="gridlove-search-form" action="http://staticmultimedia.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form>		</li>
	</ul>
</li>			</ul>
        </div>
        
    </div>
</div>

							<div id="gridlove-header-sticky" class="gridlove-header-sticky">
	<div class="container">
		
		<div class="gridlove-slot-l">
						
<div class="gridlove-site-branding  ">
			<span class="site-title h1"><a href="http://staticmultimedia.com/" rel="home"><img class="gridlove-logo" src="http://staticmultimedia.com/wp-content/uploads/2017/07/logo_main.png" alt="Static Multimedia"></a></span>
	
	
</div>

		</div>	
		<div class="gridlove-slot-r">
			<nav class="gridlove-main-navigation">	
				<ul id="menu-blog-menu-1" class="gridlove-main-nav gridlove-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117607"><a href="http://www.staticmultimedia.com">Front Page</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-105659"><a href="http://www.staticmultimedia.com">Articles</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117550"><a href="http://staticmultimedia.com/category/fashion-lifestyle/">Fashion &#038; Lifestyle</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112054"><a href="http://staticmultimedia.com/movies">Movies</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-105663"><a href="http://staticmultimedia.com/video-games">Video Games</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117986"><a href="http://audio.staticmultimedia.com">Audio</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-117545"><a href="http://video.staticmultimedia.com">Video</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117560"><a href="http://video.staticmultimedia.com/category/movies/">Movies</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117561"><a href="http://video.staticmultimedia.com/category/music/">Music</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117562"><a href="http://video.staticmultimedia.com/category/video-games/">Video Games</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117987"><a>//</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117546"><a href="http://cityguide.staticmultimedia.com">City Guide</a></li>
</ul>	</nav>     
				<ul class="gridlove-actions gridlove-menu">
					<li class="gridlove-actions-button gridlove-action-search">
	<span>
		<i class="fa fa-search"></i>
	</span>
	<ul class="sub-menu">
		<li>
			<form class="gridlove-search-form" action="http://staticmultimedia.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form>		</li>
	</ul>
</li>			</ul>
		</div>
	</div>
</div>			
	</header>

	<div id="gridlove-header-responsive" class="gridlove-header-responsive hidden-lg-up">

	<div class="container">
		
		
<div class="gridlove-site-branding  ">
			<span class="site-title h1"><a href="http://staticmultimedia.com/" rel="home"><img class="gridlove-logo" src="http://staticmultimedia.com/wp-content/uploads/2017/07/logo_main.png" alt="Static Multimedia"></a></span>
	
	
</div>


		

<ul class="gridlove-actions gridlove-menu">

																<li class="gridlove-actions-button gridlove-action-search">
	<span>
		<i class="fa fa-search"></i>
	</span>
	<ul class="sub-menu">
		<li>
			<form class="gridlove-search-form" action="http://staticmultimedia.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form>		</li>
	</ul>
</li>				
			<li class="gridlove-actions-button">
	<span class="gridlove-sidebar-action">
		<i class="fa fa-bars"></i>
	</span>
</li>	
</ul>
	</div>

</div>



	<div id="cover" class="gridlove-cover-area gridlove-cover-single">
		<div class="gridlove-cover-item">
        	<div class="gridlove-cover-bg">
    		<span class="gridlove-cover">
        		<img width="1100" height="400" src="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/theveil.jpg?resize=1100%2C400" class="attachment-gridlove-cover size-gridlove-cover wp-post-image" alt="" srcset="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/theveil.jpg?w=1100 1100w, https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/theveil.jpg?resize=300%2C109 300w, https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/theveil.jpg?resize=768%2C279 768w, https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/theveil.jpg?resize=1024%2C372 1024w, https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/theveil.jpg?resize=740%2C269 740w" sizes="(max-width: 1100px) 100vw, 1100px" />        		 
        	</span>  
        </div>
	  
</div>	</div>



<div id="content" class="gridlove-site-content container gridlove-sidebar-right">

    <div class="row">

    	
	
	
		<div class="gridlove-share-wrapper">
			<div class="gridlove-share gridlove-box gridlove-sticky-share">

									<a href="javascript:void(0);" class="gridlove-facebook gridlove-share-item" data-url="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fdirector-brent-ryan-green-releases-the-veil%2F&amp;t=Director+Brent+Ryan+Green+Releases+%26%238220%3BThe+Veil%26%238221%3B"><i class="fa fa-facebook"></i></a>									<a href="javascript:void(0);" class="gridlove-twitter gridlove-share-item" data-url="http://twitter.com/intent/tweet?url=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fdirector-brent-ryan-green-releases-the-veil%2F&amp;text=Director+Brent+Ryan+Green+Releases+%26%238220%3BThe+Veil%26%238221%3B"><i class="fa fa-twitter"></i></a>									<a href="javascript:void(0);"  class="gridlove-reddit gridlove-share-item" data-url="http://www.reddit.com/submit?url=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fdirector-brent-ryan-green-releases-the-veil%2F&amp;title=Director+Brent+Ryan+Green+Releases+%26%238220%3BThe+Veil%26%238221%3B"><i class="fa fa-reddit-alien"></i></a>									<a href="javascript:void(0);"  class="gridlove-pinterest gridlove-share-item" data-url="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fstaticmultimedia.com%2Fmovies%2Fdirector-brent-ryan-green-releases-the-veil%2F&amp;media=https%3A%2F%2Fi0.wp.com%2Fstaticmultimedia.com%2Fwp-content%2Fuploads%2F2017%2F08%2Ftheveil.jpg%3Ffit%3D1100%252C400&amp;description=Director+Brent+Ryan+Green+Releases+%26%238220%3BThe+Veil%26%238221%3B"><i class="fa fa-pinterest-p"></i></a>				
			</div>
		</div>

		

        <div class="gridlove-content gridlove-single-layout-7">

                            
                <article id="post-118257" class="gridlove-box box-vm post-118257 post type-post status-publish format-standard has-post-thumbnail hentry category-movies">
	<div class="box-inner-p-bigger box-single">
		<div class="entry-header">
		<div class="entry-category">
	    
	    	        <a href="http://staticmultimedia.com/category/movies/" class="gridlove-cat gridlove-cat-5">Movies</a>	    	</div>

    <h1 class="entry-title">Director Brent Ryan Green Releases &#8220;The Veil&#8221;</h1>
        	<div class="entry-meta"><div class="meta-item meta-author"><span class="vcard author"><span class="fn"><a href="http://staticmultimedia.com/author/julie-burke/"><img alt='' src='http://2.gravatar.com/avatar/5e7bed84d37614fff8e8c03d38da5836?s=24&#038;d=mm&#038;r=g' class='avatar avatar-24 photo' height='24' width='24' /> Julie Burke</a></span></span></div><div class="meta-item meta-date"><span class="updated">Mon, Aug 14</span></div></div>
    
</div>	    	<div class="entry-headline h5">
		<p>Growing up, writer/director/producer Brent Ryan Green didn&#8217;t want to make movies. So how did it happen that the producer turned director is behind one of the biggest fantasy action movies opening this month, The Veil?</p>
	</div>


<div class="entry-content">
                            
    <p><em>The Veil</em> is set in a war-torn land where tribal factions live in fear of annihilation, and tells the story of a deadly warrior leading a destructive war campaign. When he is betrayed by his own and left for dead, he is healed by a mysterious princess and taken in by a hidden tribe that believes he was chosen to wage a final battle.</p>
<p><strong>How does one get into filmmaking? Or let me rephrase that, how did you?</strong></p>
<p>Growing up, I never dreamed or even thought about making films.  It wasn&#8217;t until I was in college and had a chance opportunity to go work on a film.   Even then I had no desire to work in movie business, I just thought it would be a fun adventure. After working on that film in Panama for 4 months though, it changed everything.  The process of making film, bring hundreds of people together to tell a visual story&#8230;  I was hooked. </p>
<p>For other people I would do the same.  Try and get work as a PA on a film.  Just it being hard, you will gain so much insight.  At the same time ,just start making your own film. </p>
<p><strong>How did get involved in <em>The Veil</em>?</strong></p>
<p><em>The Veil</em> was something that Jeff Goldberg, the writer and producer, and I came up with. While working for 4 years on short films, we had been looking for the perfect feature project. But after reading hundreds of script it was clear we would have to develop something ourselves. </p>
<p>This being my first feature film, we had to be strategic about the script.  We knew my home state of Oklahoma would be a perfect place to film. Oklahoma has a 37% cash back rebate program and some really amazing locations that had not been filmed before.  That along with what we thought was an attainable budget in mind was the genesis of the project.</p>
<p><strong>Have you your own production company? Is that a necessity if you want to make a movie?</strong></p>
<p>Not at all, but it doesn’t hurt.  Just depends on what you are trying to do.  Most films need to set up there own separate LLC anyways.   The advantage of having a production company would be things like insurance and infrastructure.  I think it’s better to have little to no overhead and be as flexible as possible.  Even right now Toy Gun Films currently has no full time employees.  We just staff up as needed based on the project. </p>
<p><img src="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/theveil2.jpg?resize=300%2C340" alt="" class="alignleft size-full wp-image-118264" srcset="https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/theveil2.jpg?w=300 300w, https://i0.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/theveil2.jpg?resize=265%2C300 265w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /><strong>How many hats did you wear on this movie?</strong></p>
<p>I was the director and producer of the film.  So everything that comes with that and probably a little more.  But we had hundreds of amazing cast and crew who all gave 100% to the film, which without it wouldn’t have been possible. </p>
<p><strong>Is there anything about the independent filmmaking business you still struggle with?</strong></p>
<p>The whole thing is a struggle.  Distribution is very tough.  Unless you project is an extremely micro budget.  You have to make the film with distribution not only in mind but planned out ahead of time.   Otherwise you will end up with a very expensive film and nowhere for it to go. </p>
<p><strong>Where do you think your strengths lie as a filmmaker?</strong></p>
<p>I just love visual story telling.  Bringing all the departments together and creating a team of creative people is what excites me.  I love being on set with the cast and crew.  The process of filming the movie is the best part by far.</p>
<p><strong>How important is marketing? Do you think a project can make any dent without it these days?</strong></p>
<p>Even with marketing I am not sure you can make a dent.  It’s by far my least favorite part.  I just love making the films and really rely on sales agents and distributors for that part.   That being said you really can’t take you eye off any apart of the process or trust someone else to go above and beyond.  So you have to stay involved and connect to the whole process. </p>
<p><strong>What do you hope audiences get from it?</strong></p>
<p>I hope they have an entertaining time.  There is more to the film but that&#8217;s all icing on the cake.   I also hope all the William levy fans get to see him in a new light.  As a true action star. </p>
<p><em>The Veil</em> – now showing in select theaters and available on digital.</p>

    
    
</div>	    	    
	
	
		<nav class="gridlove-prev-next-nav">
				<div class="gridlove-prev-link">
				
					
						<a href="http://staticmultimedia.com/movies/armin-siljkovic-presents-death-waits-for-no-man/">
							<span class="gridlove-pn-ico"><i class="fa fa fa-chevron-left"></i></span>
							<span class="gridlove-pn-link">Armin Siljkovic  Presents &#8216;Death Waits For No Man&#8221;</span>
						</a>

					

								</div>
				<div class="gridlove-next-link">
				
					
						<a href="http://staticmultimedia.com/movies/writer-director-william-scherer-discusses-new-hitchcockian-thriller/">
							<span class="gridlove-pn-ico"><i class="fa fa fa-chevron-right"></i></span>
							<span class="gridlove-pn-link">Writer-director William Scherer Discusses New Hitchcockian Thriller</span>
						</a>
					

								</div>

		</nav>

	

	</div>
</article>
                            

            	<div class="gridlove-ad"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- city guide sidebar -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-6137011645901412"
     data-ad-slot="6141942194"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

            
            
                
    
    
        <div class="gridlove-related">
            <div class="gridlove-module">

                <div class="module-header"><div class="module-title"><h4 class="h2">You may also like</h2></div></div>                <div class="row">
                    
                        <div class="col-lg-12 col-md-12 col-sm-12">
                                                        <article class="gridlove-post gridlove-post-b gridlove-box  post-118279 post type-post status-publish format-standard has-post-thumbnail hentry category-movies">

            <div class="entry-image">
            <a href="http://staticmultimedia.com/movies/hats-that-channel-your-bad-ass-spirit/" title="Hats that Channel Your Bad Ass Spirit"><img width="385" height="300" src="https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/dolls-kill.jpg?resize=385%2C300" class="attachment-gridlove-b8 size-gridlove-b8 wp-post-image" alt="" srcset="https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/dolls-kill.jpg?resize=385%2C300 385w, https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/dolls-kill.jpg?zoom=2&amp;resize=385%2C300 770w, https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/dolls-kill.jpg?zoom=3&amp;resize=385%2C300 1155w" sizes="(max-width: 385px) 100vw, 385px" /></a>
        </div>
    
    <div class="box-inner-ptbr box-col-b entry-sm-overlay">
        <div class="box-inner-ellipsis">
            <div class="entry-category">
                                                    
                                    <a href="http://staticmultimedia.com/category/movies/" class="gridlove-cat gridlove-cat-5">Movies</a>                            </div>
            
            <h2 class="entry-title h3"><a href="http://staticmultimedia.com/movies/hats-that-channel-your-bad-ass-spirit/">Hats that Channel Your Bad Ass Spirit</a></h2>            <div class="entry-content"><p>From dad hats, and wide brim’s to beanies, bucket’s and beret’s, Dolls Kill has an online boutique offering an eclectic selection of hats that’s sure to excite any rebellious sprit and attitude. Edgy designs mixed with a bit of punk rock, glam, goth...</p>
</div>

        </div>
  
                    <div class="entry-meta"><div class="meta-item meta-author"><span class="vcard author"><span class="fn"><a href="http://staticmultimedia.com/author/rachelmargolin/"><img alt='' src='http://0.gravatar.com/avatar/33d60494351be11453295ba9105c5d32?s=24&#038;d=mm&#038;r=g' class='avatar avatar-24 photo' height='24' width='24' /> Rachel Margolin</a></span></span></div></div>
         
    </div>    

       
</article>                        </div>

                    
                        <div class="col-lg-12 col-md-12 col-sm-12">
                                                        <article class="gridlove-post gridlove-post-b gridlove-box  post-118273 post type-post status-publish format-standard has-post-thumbnail hentry category-movies tag-feature tag-interview">

            <div class="entry-image">
            <a href="http://staticmultimedia.com/movies/armin-siljkovic-presents-death-waits-for-no-man/" title="Armin Siljkovic  Presents &#8216;Death Waits For No Man&#8221;"><img width="385" height="300" src="https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/death-waits-for-no-one-1.jpg?resize=385%2C300" class="attachment-gridlove-b8 size-gridlove-b8 wp-post-image" alt="" srcset="https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/death-waits-for-no-one-1.jpg?resize=385%2C300 385w, https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/death-waits-for-no-one-1.jpg?zoom=2&amp;resize=385%2C300 770w, https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/death-waits-for-no-one-1.jpg?zoom=3&amp;resize=385%2C300 1155w" sizes="(max-width: 385px) 100vw, 385px" /></a>
        </div>
    
    <div class="box-inner-ptbr box-col-b entry-sm-overlay">
        <div class="box-inner-ellipsis">
            <div class="entry-category">
                                                    
                                    <a href="http://staticmultimedia.com/category/movies/" class="gridlove-cat gridlove-cat-5">Movies</a>                            </div>
            
            <h2 class="entry-title h3"><a href="http://staticmultimedia.com/movies/armin-siljkovic-presents-death-waits-for-no-man/">Armin Siljkovic  Presents &#8216;Death Waits For No Man&#8221;</a></h2>            <div class="entry-content"><p>Armin Silkkovic is the writer/director of a promising new noir-thriller called Death Waits for No Man. The movie tells of a group of online social justice activists venture deep into the woods to uncover the truth behind a recent series of gruesome...</p>
</div>

        </div>
  
                    <div class="entry-meta"><div class="meta-item meta-author"><span class="vcard author"><span class="fn"><a href="http://staticmultimedia.com/author/julie-burke/"><img alt='' src='http://2.gravatar.com/avatar/5e7bed84d37614fff8e8c03d38da5836?s=24&#038;d=mm&#038;r=g' class='avatar avatar-24 photo' height='24' width='24' /> Julie Burke</a></span></span></div></div>
         
    </div>    

       
</article>                        </div>

                    
                        <div class="col-lg-12 col-md-12 col-sm-12">
                                                        <article class="gridlove-post gridlove-post-b gridlove-box  post-118246 post type-post status-publish format-standard has-post-thumbnail hentry category-movies">

            <div class="entry-image">
            <a href="http://staticmultimedia.com/movies/writer-director-william-scherer-discusses-new-hitchcockian-thriller/" title="Writer-director William Scherer Discusses New Hitchcockian Thriller"><img width="385" height="300" src="https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/wscherer.jpg?resize=385%2C300" class="attachment-gridlove-b8 size-gridlove-b8 wp-post-image" alt="" srcset="https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/wscherer.jpg?resize=385%2C300 385w, https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/wscherer.jpg?zoom=2&amp;resize=385%2C300 770w" sizes="(max-width: 385px) 100vw, 385px" /></a>
        </div>
    
    <div class="box-inner-ptbr box-col-b entry-sm-overlay">
        <div class="box-inner-ellipsis">
            <div class="entry-category">
                                                    
                                    <a href="http://staticmultimedia.com/category/movies/" class="gridlove-cat gridlove-cat-5">Movies</a>                            </div>
            
            <h2 class="entry-title h3"><a href="http://staticmultimedia.com/movies/writer-director-william-scherer-discusses-new-hitchcockian-thriller/">Writer-director William Scherer Discusses New Hitchcockian Thriller</a></h2>            <div class="entry-content"><p>Writer-director William Scherer’s Hitchcockian thriller “The House on Rodeo Gulch” is now available on VOD.</p>
</div>

        </div>
  
                    <div class="entry-meta"><div class="meta-item meta-author"><span class="vcard author"><span class="fn"><a href="http://staticmultimedia.com/author/julie-burke/"><img alt='' src='http://2.gravatar.com/avatar/5e7bed84d37614fff8e8c03d38da5836?s=24&#038;d=mm&#038;r=g' class='avatar avatar-24 photo' height='24' width='24' /> Julie Burke</a></span></span></div></div>
         
    </div>    

       
</article>                        </div>

                                    </div>
            </div>
        </div>

    
    

        </div>

        

	<div class="gridlove-sidebar">

		
						<div class="gridlove-sticky-sidebar">
					<div id="mks_ads_widget-2" class="widget gridlove-box mks_ads_widget"><h4 class="widget-title">Advertisement</h4>			
					
						
			
			<ul class="mks_adswidget_ul large">
	     			     				     						     					     			<li data-showind="0">
				     			<div style="width:300px; height:250px;" width="300"  height="250">
				     				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- city guide sidebar -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-6137011645901412"
     data-ad-slot="6141942194"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>	
				     			</div>
				     		</li>
			     				     			     			     			    	</ul>
	    
	    	  
	  		  
    	
		</div><div id="gridlove_posts_widget-2" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Trending</h4>
								
		<div class="gridlove-posts-widget ">

							
								
				<article class="post-118279 post type-post status-publish format-standard has-post-thumbnail hentry category-movies">

		            		                <div class="entry-image">
		                <a href="http://staticmultimedia.com/movies/hats-that-channel-your-bad-ass-spirit/" title="Hats that Channel Your Bad Ass Spirit">
		                   	<img width="80" height="60" src="https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/dolls-kill.jpg?resize=80%2C60" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" srcset="https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/dolls-kill.jpg?resize=80%2C60 80w, https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/dolls-kill.jpg?zoom=2&amp;resize=80%2C60 160w, https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/dolls-kill.jpg?zoom=3&amp;resize=80%2C60 240w" sizes="(max-width: 80px) 100vw, 80px" />		                </a>
		                </div>
		            
		            <div class="entry-header">
		                <h6><a href="http://staticmultimedia.com/movies/hats-that-channel-your-bad-ass-spirit/">Hats that Channel Your Bad Ass Spirit</a></h6>		                		            </div>

				</article>

				
				
							
								
				<article class="post-118273 post type-post status-publish format-standard has-post-thumbnail hentry category-movies tag-feature tag-interview">

		            		                <div class="entry-image">
		                <a href="http://staticmultimedia.com/movies/armin-siljkovic-presents-death-waits-for-no-man/" title="Armin Siljkovic  Presents &#8216;Death Waits For No Man&#8221;">
		                   	<img width="80" height="60" src="https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/death-waits-for-no-one-1.jpg?resize=80%2C60" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" srcset="https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/death-waits-for-no-one-1.jpg?resize=80%2C60 80w, https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/death-waits-for-no-one-1.jpg?zoom=2&amp;resize=80%2C60 160w, https://i1.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/death-waits-for-no-one-1.jpg?zoom=3&amp;resize=80%2C60 240w" sizes="(max-width: 80px) 100vw, 80px" />		                </a>
		                </div>
		            
		            <div class="entry-header">
		                <h6><a href="http://staticmultimedia.com/movies/armin-siljkovic-presents-death-waits-for-no-man/">Armin Siljkovic  Presents &#8216;Death Waits For No Man&#8221;</a></h6>		                		            </div>

				</article>

				
				
							
								
				<article class="post-118270 post type-post status-publish format-standard has-post-thumbnail hentry category-video-games">

		            		                <div class="entry-image">
		                <a href="http://staticmultimedia.com/video-games/sonic-mania-delayed-two-weeks-on-pc/" title="Sonic Mania Delayed Two Weeks on PC">
		                   	<img width="80" height="60" src="https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/sonic-mania.jpg?resize=80%2C60" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" srcset="https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/sonic-mania.jpg?resize=80%2C60 80w, https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/sonic-mania.jpg?zoom=2&amp;resize=80%2C60 160w, https://i2.wp.com/staticmultimedia.com/wp-content/uploads/2017/08/sonic-mania.jpg?zoom=3&amp;resize=80%2C60 240w" sizes="(max-width: 80px) 100vw, 80px" />		                </a>
		                </div>
		            
		            <div class="entry-header">
		                <h6><a href="http://staticmultimedia.com/video-games/sonic-mania-delayed-two-weeks-on-pc/">Sonic Mania Delayed Two Weeks on PC</a></h6>		                		            </div>

				</article>

				
				
			
		</div>

		
		
		</div>				</div>
		
	</div>

    </div>
        
</div>




<div id="footer" class="gridlove-footer">

	
	        <div class="container">
	            <div class="row">
	                
											<div class="col-lg-3 col-md-6 col-sm-12">
													</div>
											<div class="col-lg-3 col-md-6 col-sm-12">
													</div>
											<div class="col-lg-3 col-md-6 col-sm-12">
													</div>
											<div class="col-lg-3 col-md-6 col-sm-12">
													</div>
					
	            </div>
	        </div>

	
    
	        <div class="gridlove-copyright">
	            <div class="container">
	                <p style="text-align: center">Copyright &copy; 2017 Static Multimedia</p>	            </div>
	        </div>

	
</div>

<div class="gridlove-sidebar-action-wrapper">

	<span class="gridlove-action-close"><i class="fa fa-times" aria-hidden="true"></i></span>

	<div class="gridlove-sidebar-action-inside">

		<div class="hidden-lg-up widget gridlove-box widget_nav_menu">
					<ul id="menu-blog-menu-2" class="gridlove-mobile-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117607"><a href="http://www.staticmultimedia.com">Front Page</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-105659"><a href="http://www.staticmultimedia.com">Articles</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117550"><a href="http://staticmultimedia.com/category/fashion-lifestyle/">Fashion &#038; Lifestyle</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112054"><a href="http://staticmultimedia.com/movies">Movies</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-105663"><a href="http://staticmultimedia.com/video-games">Video Games</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117986"><a href="http://audio.staticmultimedia.com">Audio</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-117545"><a href="http://video.staticmultimedia.com">Video</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117560"><a href="http://video.staticmultimedia.com/category/movies/">Movies</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117561"><a href="http://video.staticmultimedia.com/category/music/">Music</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117562"><a href="http://video.staticmultimedia.com/category/video-games/">Video Games</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117987"><a>//</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117546"><a href="http://cityguide.staticmultimedia.com">City Guide</a></li>
</ul>		</div>

		

	</div>

</div>

<div class="gridlove-sidebar-action-overlay"></div>
<script type='text/javascript' src='http://staticmultimedia.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201733'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gridlove_js_settings = {"rtl_mode":"","header_sticky":"1","header_sticky_offset":"60","header_sticky_up":"","logo":"http:\/\/staticmultimedia.com\/wp-content\/uploads\/2017\/07\/logo_main.png","logo_retina":"","logo_mini":"","logo_mini_retina":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://staticmultimedia.com/wp-content/themes/gridlove/assets/js/min.js?ver=1.3'></script>
<script type='text/javascript' src='http://staticmultimedia.com/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201733.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.2.1',blog:'50383145',post:'118257',tz:'0',srv:'staticmultimedia.com'} ]);
	_stq.push([ 'clickTrackerInit', '50383145', '118257' ]);
</script>
</body>

</html>